Install VLC Media Player in Ubuntu 11.04 (Natty Narwhal)

Ubuntu Natty VLC

Without doubt VLC is one among the best media players available till date. Why because VLC can play almost all media file formats under the sun. Available on all major platforms including Linux, Windows and Mac OS, VLC can play all popular multimedia formats like MP4, WMV, H264, DivX, AAC and many others.

If you want to download and install VLC player in Ubuntu 11.04 add the PPA to repository by following the steps below.

Steps to install VLC player in Ubuntu 11.04 (Command Line):

1. Open the terminal and add PPA by executing the following command,

sudo add-apt-repository ppa:n-muench/vlc

2. Update and install VLC media player along with few other plugins,

sudo apt-get update
sudo apt-get install vlc mozilla-plugin-vlc vlc-plugin-pulse

3. Done.

 

VLC Ubuntu GNOME

Comments

  1. after i followed your instructions my terminal showes the following problem, what might be the solution for me
    dilz@dilz-VirtualBox:~$ sudo add-apt-repository ppa:n-muench/vlc
    [sudo] password for dilz:
    Exception in thread Thread-1:
    Traceback (most recent call last):
    File “/usr/lib/python2.7/threading.py”, line 552, in __bootstrap_inner
    self.run()
    File “/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py”, line 63, in run
    self.add_ppa_signing_key(self.ppa_path)
    File “/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py”, line 79, in add_ppa_signing_key
    lp_page = urlopen(req).read()
    File “/usr/lib/python2.7/urllib2.py”, line 126, in urlopen
    return _opener.open(url, data, timeout)
    File “/usr/lib/python2.7/urllib2.py”, line 391, in open
    response = self._open(req, data)
    File “/usr/lib/python2.7/urllib2.py”, line 409, in _open
    ‘_open’, req)
    File “/usr/lib/python2.7/urllib2.py”, line 369, in _call_chain
    result = func(*args)
    File “/usr/lib/python2.7/urllib2.py”, line 1193, in https_open
    return self.do_open(httplib.HTTPSConnection, req)
    File “/usr/lib/python2.7/urllib2.py”, line 1156, in do_open
    r = h.getresponse(buffering=True)
    File “/usr/lib/python2.7/httplib.py”, line 1027, in getresponse
    response.begin()
    File “/usr/lib/python2.7/httplib.py”, line 407, in begin
    version, status, reason = self._read_status()
    File “/usr/lib/python2.7/httplib.py”, line 371, in _read_status
    raise BadStatusLine(line)
    BadStatusLine: ”

    dilz@dilz-VirtualBox:~$ sudo apt-get update
    E: Could not get lock /var/lib/apt/lists/lock – open (11: Resource temporarily unavailable)
    E: Unable to lock directory /var/lib/apt/lists/
    dilz@dilz-VirtualBox:~$ sudo apt-get install vlc mozilla-plugin-vlc vlc-plugin-pulse
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    mozilla-plugin-vlc : Depends: vlc-nox (= 1.1.9-1ubuntu1.1) but it is not going to be installed
    vlc : Depends: vlc-nox (= 1.1.9-1ubuntu1.1) but it is not going to be installed
    Depends: libavcodec52 (>= 4:0.6-1~) but it is not installable or
    libavcodec-extra-52 (>= 4:0.6-1~) but it is not installable
    Depends: libavutil50 (>= 4:0.6-1~) but it is not installable or
    libavutil-extra-50 (>= 4:0.6-1~) but it is not installable
    Depends: libqtcore4 (>= 4:4.7.0~beta1) but it is not installable
    Depends: libqtgui4 (>= 4:4.5.3) but it is not installable
    Depends: libsdl-image1.2 (>= 1.2.10) but it is not installable
    Depends: libtar but it is not installable
    Depends: libva-x11-1 but it is not installable
    Depends: libva1 but it is not installable
    Depends: libxcb-keysyms1 (>= 0.3.6) but it is not installable
    Depends: libxcb-randr0 (>= 1.1) but it is not installable
    Depends: libxcb-xv0 (>= 1.2) but it is not installable
    Recommends: vlc-plugin-notify (= 1.1.9-1ubuntu1.1) but it is not going to be installed
    vlc-plugin-pulse : Depends: vlc-nox (= 1.1.9-1ubuntu1.1) but it is not going to be installed
    E: Broken packages
    dilz@dilz-VirtualBox:~$

  2. ajmal basil says:

    i love it

  3. George Joy says:

    Dear Binoy,

    Can you suggest me a way to Install VLC player in a Live Bootable USB of Ubuntu 11.04 version
    I tried the “persistent file” method but it didn’t work out and in most of the case when i tried it was saying there is no enough space on disk
    Or else is it possible to copy and paste codec files in some folder in this USB there by when totem player search for the codec it can find automatically

  4. m not able to install vlc. first 2 commands showed no problem but 3rd command of installing should d following error-

    Reading package lists… Error!
    E: Encountered a section with no Package: header
    E: Problem with MergeList /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_natty_main_i18n_Translation-en
    E: The package lists or status file could not be parsed or opened.

Trackbacks

  1. [...] ya lo tenemos. Fuente: Com Pixels Comparte y [...]